diff options
author | 3gg <3gg@shellblade.net> | 2023-06-17 20:21:58 -0700 |
---|---|---|
committer | 3gg <3gg@shellblade.net> | 2023-06-17 20:21:58 -0700 |
commit | 08ec3a7a1fdb16cbb52b05f934bd001ca38bd991 (patch) | |
tree | 664da276c93ae301c0bac038cd011afda6396ac3 /error/CMakeLists.txt | |
parent | 2f8ff39a8d95b95288875d92abb74b1428713906 (diff) |
Add error library.
Diffstat (limited to 'error/CMakeLists.txt')
-rw-r--r-- | error/CMakeLists.txt | 14 |
1 files changed, 14 insertions, 0 deletions
diff --git a/error/CMakeLists.txt b/error/CMakeLists.txt new file mode 100644 index 0000000..e47a1f9 --- /dev/null +++ b/error/CMakeLists.txt | |||
@@ -0,0 +1,14 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | project(error) | ||
4 | |||
5 | add_library(error | ||
6 | src/error.c) | ||
7 | |||
8 | target_include_directories(error PUBLIC | ||
9 | include) | ||
10 | |||
11 | target_link_libraries(error | ||
12 | cstring) | ||
13 | |||
14 | target_compile_options(error PRIVATE -Wall -Wextra) | ||