diff options
author | 3gg <3gg@shellblade.net> | 2024-02-13 17:51:51 -0800 |
---|---|---|
committer | 3gg <3gg@shellblade.net> | 2024-02-13 17:51:51 -0800 |
commit | e153be0be2fb8df6656292daab3fa59963c76737 (patch) | |
tree | 7cca3fc134553017cb3c259db1dca33c98556109 /mempool/CMakeLists.txt | |
parent | 84bdfa4a23f5b8daa7921541b007518bc634be0f (diff) |
Let memory allocators trap by default when attempting to allocate beyond capacity.
Diffstat (limited to 'mempool/CMakeLists.txt')
-rw-r--r-- | mempool/CMakeLists.txt | 3 |
1 files changed, 3 insertions, 0 deletions
diff --git a/mempool/CMakeLists.txt b/mempool/CMakeLists.txt index fe3e2a5..8c9dd30 100644 --- a/mempool/CMakeLists.txt +++ b/mempool/CMakeLists.txt | |||
@@ -10,6 +10,9 @@ add_library(mempool | |||
10 | target_include_directories(mempool PUBLIC | 10 | target_include_directories(mempool PUBLIC |
11 | include) | 11 | include) |
12 | 12 | ||
13 | target_link_libraries(mempool PRIVATE | ||
14 | cassert) | ||
15 | |||
13 | target_compile_options(mempool PRIVATE -Wall -Wextra) | 16 | target_compile_options(mempool PRIVATE -Wall -Wextra) |
14 | 17 | ||
15 | # Test | 18 | # Test |