diff options
Diffstat (limited to 'list/CMakeLists.txt')
-rw-r--r-- | list/CMakeLists.txt | 23 |
1 files changed, 23 insertions, 0 deletions
diff --git a/list/CMakeLists.txt b/list/CMakeLists.txt new file mode 100644 index 0000000..5d11d28 --- /dev/null +++ b/list/CMakeLists.txt | |||
@@ -0,0 +1,23 @@ | |||
1 | cmake_minimum_required(VERSION 3.16) | ||
2 | |||
3 | project(list) | ||
4 | |||
5 | # Library | ||
6 | |||
7 | add_library(list | ||
8 | src/list.c) | ||
9 | |||
10 | target_include_directories(list PUBLIC | ||
11 | include) | ||
12 | |||
13 | target_compile_options(list PRIVATE -Wall -Wextra) | ||
14 | |||
15 | # Test | ||
16 | |||
17 | add_executable(list_test | ||
18 | test/list_test.c) | ||
19 | |||
20 | target_link_libraries(list_test | ||
21 | list) | ||
22 | |||
23 | target_compile_options(list_test PRIVATE -DUNIT_TEST -Wall -Wextra) | ||