diff options
Diffstat (limited to 'random/CMakeLists.txt')
-rw-r--r-- | random/CMakeLists.txt | 10 |
1 files changed, 10 insertions, 0 deletions
diff --git a/random/CMakeLists.txt b/random/CMakeLists.txt new file mode 100644 index 0000000..ec80b1d --- /dev/null +++ b/random/CMakeLists.txt | |||
@@ -0,0 +1,10 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | project(random) | ||
4 | |||
5 | add_library(random | ||
6 | src/mt19937-64.c) | ||
7 | |||
8 | target_include_directories(random PUBLIC include) | ||
9 | |||
10 | target_compile_options(random PRIVATE -Wall -Wextra) | ||