diff options
Diffstat (limited to 'game/CMakeLists.txt')
-rw-r--r-- | game/CMakeLists.txt | 22 |
1 files changed, 22 insertions, 0 deletions
diff --git a/game/CMakeLists.txt b/game/CMakeLists.txt new file mode 100644 index 0000000..3a88bb7 --- /dev/null +++ b/game/CMakeLists.txt | |||
@@ -0,0 +1,22 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | add_subdirectory(src/plugins) | ||
4 | |||
5 | project(game) | ||
6 | |||
7 | add_executable(game | ||
8 | src/game.c) | ||
9 | |||
10 | target_include_directories(game PRIVATE | ||
11 | src/) | ||
12 | |||
13 | target_link_libraries(game PRIVATE | ||
14 | cstring | ||
15 | error | ||
16 | gfx | ||
17 | gfx-app | ||
18 | list | ||
19 | log | ||
20 | math | ||
21 | mempool | ||
22 | plugin) | ||