diff options
Diffstat (limited to 'game/src/plugins/CMakeLists.txt')
-rw-r--r-- | game/src/plugins/CMakeLists.txt | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/game/src/plugins/CMakeLists.txt b/game/src/plugins/CMakeLists.txt new file mode 100644 index 0000000..ecb2a45 --- /dev/null +++ b/game/src/plugins/CMakeLists.txt | |||
@@ -0,0 +1,17 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | project(plugins) | ||
4 | |||
5 | set(LINK_LIBRARIES cstring math gfx) | ||
6 | |||
7 | add_library(gltf_view SHARED | ||
8 | gltf_view.c) | ||
9 | |||
10 | add_library(texture_view SHARED | ||
11 | texture_view.c) | ||
12 | |||
13 | target_link_libraries(gltf_view PUBLIC | ||
14 | ${LINK_LIBRARIES}) | ||
15 | |||
16 | target_link_libraries(texture_view PUBLIC | ||
17 | ${LINK_LIBRARIES}) | ||