diff options
Diffstat (limited to 'game/src/plugins/CMakeLists.txt')
-rw-r--r-- | game/src/plugins/CMakeLists.txt | 18 |
1 files changed, 15 insertions, 3 deletions
diff --git a/game/src/plugins/CMakeLists.txt b/game/src/plugins/CMakeLists.txt index ecb2a45..e5abbb8 100644 --- a/game/src/plugins/CMakeLists.txt +++ b/game/src/plugins/CMakeLists.txt | |||
@@ -2,16 +2,28 @@ cmake_minimum_required(VERSION 3.0) | |||
2 | 2 | ||
3 | project(plugins) | 3 | project(plugins) |
4 | 4 | ||
5 | set(LINK_LIBRARIES cstring math gfx) | 5 | set(LINK_LIBRARIES cstring math gfx gfx-app) |
6 | |||
7 | # GLTF viewer | ||
6 | 8 | ||
7 | add_library(gltf_view SHARED | 9 | add_library(gltf_view SHARED |
8 | gltf_view.c) | 10 | gltf_view.c) |
9 | 11 | ||
12 | target_link_libraries(gltf_view PUBLIC | ||
13 | ${LINK_LIBRARIES}) | ||
14 | |||
15 | # Texture viewer | ||
16 | |||
10 | add_library(texture_view SHARED | 17 | add_library(texture_view SHARED |
11 | texture_view.c) | 18 | texture_view.c) |
12 | 19 | ||
13 | target_link_libraries(gltf_view PUBLIC | 20 | target_link_libraries(texture_view PUBLIC |
14 | ${LINK_LIBRARIES}) | 21 | ${LINK_LIBRARIES}) |
15 | 22 | ||
16 | target_link_libraries(texture_view PUBLIC | 23 | # Pong |
24 | |||
25 | add_library(pong SHARED | ||
26 | pong.c) | ||
27 | |||
28 | target_link_libraries(pong PUBLIC | ||
17 | ${LINK_LIBRARIES}) | 29 | ${LINK_LIBRARIES}) |