diff options
Diffstat (limited to 'gfx-iso/CMakeLists.txt')
-rw-r--r-- | gfx-iso/CMakeLists.txt | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/gfx-iso/CMakeLists.txt b/gfx-iso/CMakeLists.txt new file mode 100644 index 0000000..8f95f7f --- /dev/null +++ b/gfx-iso/CMakeLists.txt | |||
@@ -0,0 +1,30 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | project(isogfx) | ||
4 | |||
5 | set(CMAKE_C_STANDARD 11) | ||
6 | set(CMAKE_C_STANDARD_REQUIRED On) | ||
7 | set(CMAKE_C_EXTENSIONS Off) | ||
8 | |||
9 | add_library(isogfx | ||
10 | src/isogfx.c) | ||
11 | |||
12 | target_include_directories(isogfx PUBLIC | ||
13 | include) | ||
14 | |||
15 | target_link_libraries(isogfx PRIVATE | ||
16 | mempool) | ||
17 | |||
18 | target_compile_options(isogfx PRIVATE -Wall -Wextra -Wpedantic) | ||
19 | |||
20 | # Demo | ||
21 | |||
22 | project(isogfx-demo) | ||
23 | |||
24 | add_executable(isogfx-demo | ||
25 | demo/isogfx-demo.c) | ||
26 | |||
27 | target_link_libraries(isogfx-demo PRIVATE | ||
28 | gfx | ||
29 | gfx-app | ||
30 | isogfx) | ||