diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt new file mode 100644 index 0000000..b046871 --- /dev/null +++ b/CMakeLists.txt | |||
@@ -0,0 +1,24 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | project(ui) | ||
4 | |||
5 | set(CMAKE_C_STANDARD 17) | ||
6 | set(CMAKE_C_STANDARD_REQUIRED On) | ||
7 | set(CMAKE_C_EXTENSIONS Off) | ||
8 | |||
9 | add_subdirectory(font) | ||
10 | add_subdirectory(fontbaker) | ||
11 | |||
12 | add_library(ui | ||
13 | src/ui.c) | ||
14 | |||
15 | target_include_directories(ui PUBLIC | ||
16 | include) | ||
17 | |||
18 | target_link_libraries(ui PUBLIC | ||
19 | cassert | ||
20 | cstring | ||
21 | font | ||
22 | list) | ||
23 | |||
24 | target_compile_options(ui PRIVATE -Wall -Wextra -Wpedantic) | ||