diff options
Diffstat (limited to 'font/CMakeLists.txt')
-rw-r--r-- | font/CMakeLists.txt | 15 |
1 files changed, 15 insertions, 0 deletions
diff --git a/font/CMakeLists.txt b/font/CMakeLists.txt new file mode 100644 index 0000000..6eb6fc0 --- /dev/null +++ b/font/CMakeLists.txt | |||
@@ -0,0 +1,15 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | project(font) | ||
4 | |||
5 | set(CMAKE_C_STANDARD 17) | ||
6 | set(CMAKE_C_STANDARD_REQUIRED On) | ||
7 | set(CMAKE_C_EXTENSIONS Off) | ||
8 | |||
9 | add_library(font | ||
10 | font.c) | ||
11 | |||
12 | target_include_directories(font PUBLIC | ||
13 | .) | ||
14 | |||
15 | target_compile_options(font PRIVATE -Wall -Wextra -Wpedantic) | ||