diff options
author | 3gg <3gg@shellblade.net> | 2023-07-13 08:22:18 -0700 |
---|---|---|
committer | 3gg <3gg@shellblade.net> | 2023-07-13 08:22:18 -0700 |
commit | 9f254f0c7b03236be615b1235cf3fc765d6000ea (patch) | |
tree | f0b878ef2b431b909d9efd45c1f9ec8ed8ca54f8 /listpool/CMakeLists.txt | |
parent | fc5886c75ab2626acbc0d7b3db475d17d2cbe01f (diff) |
Add mem allocator, remove listpool.
Diffstat (limited to 'listpool/CMakeLists.txt')
-rw-r--r-- | listpool/CMakeLists.txt | 26 |
1 files changed, 0 insertions, 26 deletions
diff --git a/listpool/CMakeLists.txt b/listpool/CMakeLists.txt deleted file mode 100644 index 2dcd983..0000000 --- a/listpool/CMakeLists.txt +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | project(listpool) | ||
4 | |||
5 | # Library | ||
6 | |||
7 | add_library(listpool | ||
8 | src/listpool.c) | ||
9 | |||
10 | target_include_directories(listpool PUBLIC | ||
11 | include) | ||
12 | |||
13 | target_link_libraries(listpool | ||
14 | list) | ||
15 | |||
16 | target_compile_options(listpool PRIVATE -Wall -Wextra) | ||
17 | |||
18 | # Test | ||
19 | |||
20 | add_executable(listpool_test | ||
21 | test/listpool_test.c) | ||
22 | |||
23 | target_link_libraries(listpool_test | ||
24 | listpool) | ||
25 | |||
26 | target_compile_options(listpool_test PRIVATE -DUNIT_TEST -DNDEBUG -Wall -Wextra) | ||