diff options
author | Marc Sunet <msunet@shellblade.net> | 2022-05-07 08:09:10 -0700 |
---|---|---|
committer | Marc Sunet <msunet@shellblade.net> | 2022-05-07 08:09:10 -0700 |
commit | 344960f7470d7b6e5cb0c0b1d7e751d47063a98c (patch) | |
tree | 138d163f10f8f5c5bb8d5624d5914bc7506da33c /random/CMakeLists.txt | |
parent | e504a003cf5e88c9440ab49e10792e0e26b96c45 (diff) |
Add random library.
Diffstat (limited to 'random/CMakeLists.txt')
-rw-r--r-- | random/CMakeLists.txt | 10 |
1 files changed, 10 insertions, 0 deletions
diff --git a/random/CMakeLists.txt b/random/CMakeLists.txt new file mode 100644 index 0000000..ec80b1d --- /dev/null +++ b/random/CMakeLists.txt | |||
@@ -0,0 +1,10 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | project(random) | ||
4 | |||
5 | add_library(random | ||
6 | src/mt19937-64.c) | ||
7 | |||
8 | target_include_directories(random PUBLIC include) | ||
9 | |||
10 | target_compile_options(random PRIVATE -Wall -Wextra) | ||