diff options
Diffstat (limited to 'mempool/CMakeLists.txt')
-rw-r--r-- | mempool/CMakeLists.txt | 23 |
1 files changed, 23 insertions, 0 deletions
diff --git a/mempool/CMakeLists.txt b/mempool/CMakeLists.txt new file mode 100644 index 0000000..1ff4ff1 --- /dev/null +++ b/mempool/CMakeLists.txt | |||
@@ -0,0 +1,23 @@ | |||
1 | cmake_minimum_required(VERSION 3.16) | ||
2 | |||
3 | project(mempool) | ||
4 | |||
5 | # Library | ||
6 | |||
7 | add_library(mempool | ||
8 | src/mempool.c) | ||
9 | |||
10 | target_include_directories(mempool PUBLIC | ||
11 | include) | ||
12 | |||
13 | target_compile_options(mempool PRIVATE -Wall -Wextra) | ||
14 | |||
15 | # Test | ||
16 | |||
17 | add_executable(mempool_test | ||
18 | test/mempool_test.c) | ||
19 | |||
20 | target_link_libraries(mempool_test | ||
21 | mempool) | ||
22 | |||
23 | target_compile_options(mempool_test PRIVATE -DUNIT_TEST -DNDEBUG -Wall -Wextra) | ||