diff options
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r-- | test/CMakeLists.txt | 13 |
1 files changed, 13 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt new file mode 100644 index 0000000..102568c --- /dev/null +++ b/test/CMakeLists.txt | |||
@@ -0,0 +1,13 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | project(test) | ||
4 | |||
5 | set(CMAKE_CXX_STANDARD 20) | ||
6 | set(CMAKE_CXX_STANDARD_REQUIRED On) | ||
7 | set(CMAKE_CXX_EXTENSIONS Off) | ||
8 | |||
9 | add_library(test INTERFACE | ||
10 | test.h) | ||
11 | |||
12 | target_include_directories(test INTERFACE | ||
13 | .) | ||