diff options
Diffstat (limited to 'julia/CMakeLists.txt')
-rw-r--r-- | julia/CMakeLists.txt | 11 |
1 files changed, 11 insertions, 0 deletions
diff --git a/julia/CMakeLists.txt b/julia/CMakeLists.txt new file mode 100644 index 0000000..e5428fb --- /dev/null +++ b/julia/CMakeLists.txt | |||
@@ -0,0 +1,11 @@ | |||
1 | cmake_minimum_required(VERSION 3.28) | ||
2 | |||
3 | project(cuda_julia LANGUAGES CUDA CXX) | ||
4 | |||
5 | add_executable(cuda_julia | ||
6 | julia.cu) | ||
7 | |||
8 | # -Wpedantic causes warnings due to nvcc emitting non-standard (gcc-specific) | ||
9 | # host code. | ||
10 | # https://stackoverflow.com/questions/31000996/warning-when-compiling-cu-with-wpedantic-style-of-line-directive-is-a-gcc-ex | ||
11 | target_compile_options(cuda_julia PRIVATE -Wall -Wextra -Wno-pedantic) | ||