diff options
Diffstat (limited to 'vector_sum/CMakeLists.txt')
-rw-r--r-- | vector_sum/CMakeLists.txt | 11 |
1 files changed, 11 insertions, 0 deletions
diff --git a/vector_sum/CMakeLists.txt b/vector_sum/CMakeLists.txt new file mode 100644 index 0000000..1eea51b --- /dev/null +++ b/vector_sum/CMakeLists.txt | |||
@@ -0,0 +1,11 @@ | |||
1 | cmake_minimum_required(VERSION 3.28) | ||
2 | |||
3 | project(vector_sum LANGUAGES CUDA CXX) | ||
4 | |||
5 | add_executable(vector_sum | ||
6 | main.cu) | ||
7 | |||
8 | # -Wpedantic causes warnings due to nvcc emitting non-standard (gcc-specific) | ||
9 | # host code. | ||
10 | # https://stackoverflow.com/questions/31000996/warning-when-compiling-cu-with-wpedantic-style-of-line-directive-is-a-gcc-ex | ||
11 | target_compile_options(vector_sum PRIVATE -Wall -Wextra -Wno-pedantic) | ||