diff options
author | marsunet <marc.sunet@amd.com> | 2021-12-21 17:04:22 -0800 |
---|---|---|
committer | marsunet <marc.sunet@amd.com> | 2021-12-21 17:04:22 -0800 |
commit | fba8184491e0b7ae6fab7ac01b4600d230dc4569 (patch) | |
tree | c13194764867a4ad8f46702356b22dccc1e56dd3 /dxcommon/CMakeLists.txt | |
parent | 8b1583b65d77188ef35a89e75f145f29c3e3b5d7 (diff) |
Diffstat (limited to 'dxcommon/CMakeLists.txt')
-rw-r--r-- | dxcommon/CMakeLists.txt | 12 |
1 files changed, 12 insertions, 0 deletions
diff --git a/dxcommon/CMakeLists.txt b/dxcommon/CMakeLists.txt new file mode 100644 index 0000000..ad8e2b6 --- /dev/null +++ b/dxcommon/CMakeLists.txt | |||
@@ -0,0 +1,12 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | add_library(dxcommon | ||
4 | src/dxcommon.cc) | ||
5 | |||
6 | target_include_directories(dxcommon PUBLIC | ||
7 | ${CMAKE_CURRENT_SOURCE_DIR}/include) | ||
8 | |||
9 | target_link_libraries(dxcommon PUBLIC | ||
10 | DirectX-Headers | ||
11 | D3D12.lib | ||
12 | DXGI.lib) | ||