aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..53799c0
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,22 @@
1cmake_minimum_required(VERSION 3.0)
2
3project(dx12)
4
5set(CMAKE_CXX_STANDARD 20)
6set(CMAKE_CXX_STANDARD_REQUIRED ON)
7
8# -MT, multi-threaded statically-linked runtime library.
9#set(CMAKE_MSVC_RUNTIME_LIBRARY MultiThreaded)
10set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} /MT")
11set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} /MTd /DDEBUG")
12
13# External dependencies.
14add_subdirectory(contrib/DirectX-Headers)
15add_subdirectory(contrib/glfw)
16
17# Common libraries.
18add_subdirectory(dxcommon)
19add_subdirectory(dxwindow)
20
21# Applications.
22add_subdirectory(hello)