diff options
Diffstat (limited to 'dxcommon/CMakeLists.txt')
-rw-r--r-- | dxcommon/CMakeLists.txt | 12 |
1 files changed, 12 insertions, 0 deletions
diff --git a/dxcommon/CMakeLists.txt b/dxcommon/CMakeLists.txt new file mode 100644 index 0000000..ad8e2b6 --- /dev/null +++ b/dxcommon/CMakeLists.txt | |||
@@ -0,0 +1,12 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | add_library(dxcommon | ||
4 | src/dxcommon.cc) | ||
5 | |||
6 | target_include_directories(dxcommon PUBLIC | ||
7 | ${CMAKE_CURRENT_SOURCE_DIR}/include) | ||
8 | |||
9 | target_link_libraries(dxcommon PUBLIC | ||
10 | DirectX-Headers | ||
11 | D3D12.lib | ||
12 | DXGI.lib) | ||