diff options
author | 3gg <3gg@shellblade.net> | 2023-07-08 14:37:29 -0700 |
---|---|---|
committer | 3gg <3gg@shellblade.net> | 2023-07-08 14:37:29 -0700 |
commit | 21a0d0c1c424f7db90c3282aad4bf6ad4ef809b7 (patch) | |
tree | a6ae8a8cb4108cd33713178e67d3b482fc1fd5ee /gfx-iso/CMakeLists.txt | |
parent | 303f5dc58dd8e8266df3c62fc84d9799db8047b9 (diff) |
Load tile maps and tile sets from files.
Diffstat (limited to 'gfx-iso/CMakeLists.txt')
-rw-r--r-- | gfx-iso/CMakeLists.txt | 11 |
1 files changed, 7 insertions, 4 deletions
diff --git a/gfx-iso/CMakeLists.txt b/gfx-iso/CMakeLists.txt index 8f95f7f..b57a83f 100644 --- a/gfx-iso/CMakeLists.txt +++ b/gfx-iso/CMakeLists.txt | |||
@@ -13,18 +13,21 @@ target_include_directories(isogfx PUBLIC | |||
13 | include) | 13 | include) |
14 | 14 | ||
15 | target_link_libraries(isogfx PRIVATE | 15 | target_link_libraries(isogfx PRIVATE |
16 | filesystem | ||
16 | mempool) | 17 | mempool) |
17 | 18 | ||
18 | target_compile_options(isogfx PRIVATE -Wall -Wextra -Wpedantic) | 19 | target_compile_options(isogfx PRIVATE -Wall -Wextra -Wpedantic) |
19 | 20 | ||
20 | # Demo | 21 | # Demo |
21 | 22 | ||
22 | project(isogfx-demo) | 23 | project(isogfx-app) |
23 | 24 | ||
24 | add_executable(isogfx-demo | 25 | add_executable(isogfx-app |
25 | demo/isogfx-demo.c) | 26 | app/checkerboard.c |
27 | app/isogfx-demo.c | ||
28 | app/main.c) | ||
26 | 29 | ||
27 | target_link_libraries(isogfx-demo PRIVATE | 30 | target_link_libraries(isogfx-app PRIVATE |
28 | gfx | 31 | gfx |
29 | gfx-app | 32 | gfx-app |
30 | isogfx) | 33 | isogfx) |