summaryrefslogtreecommitdiff
path: root/gltfview/src/plugins/CMakeLists.txt
diff options
context:
space:
mode:
author3gg <3gg@shellblade.net>2023-06-16 09:38:15 -0700
committer3gg <3gg@shellblade.net>2023-06-16 09:38:15 -0700
commit520e4e67cd9ff53f3c3512c80d07193625e07e3e (patch)
treef2f8acfc2eb0d2aa279263d93af00beef7e93a1b /gltfview/src/plugins/CMakeLists.txt
parent14e6edd6bfe94089d52b5c4b6899dea23923e9be (diff)
New plugin architecture.
Diffstat (limited to 'gltfview/src/plugins/CMakeLists.txt')
-rw-r--r--gltfview/src/plugins/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/gltfview/src/plugins/CMakeLists.txt b/gltfview/src/plugins/CMakeLists.txt
new file mode 100644
index 0000000..ecb2a45
--- /dev/null
+++ b/gltfview/src/plugins/CMakeLists.txt
@@ -0,0 +1,17 @@
1cmake_minimum_required(VERSION 3.0)
2
3project(plugins)
4
5set(LINK_LIBRARIES cstring math gfx)
6
7add_library(gltf_view SHARED
8 gltf_view.c)
9
10add_library(texture_view SHARED
11 texture_view.c)
12
13target_link_libraries(gltf_view PUBLIC
14 ${LINK_LIBRARIES})
15
16target_link_libraries(texture_view PUBLIC
17 ${LINK_LIBRARIES})