diff options
Diffstat (limited to 'app/demo/CMakeLists.txt')
-rw-r--r-- | app/demo/CMakeLists.txt | 15 |
1 files changed, 15 insertions, 0 deletions
diff --git a/app/demo/CMakeLists.txt b/app/demo/CMakeLists.txt new file mode 100644 index 0000000..bbb3aae --- /dev/null +++ b/app/demo/CMakeLists.txt | |||
@@ -0,0 +1,15 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | project(gfxappdemo) | ||
4 | |||
5 | set(CMAKE_C_STANDARD 17) | ||
6 | set(CMAKE_C_STANDARD_REQUIRED On) | ||
7 | set(CMAKE_C_EXTENSIONS Off) | ||
8 | |||
9 | add_executable(gfxappdemo | ||
10 | main.c) | ||
11 | |||
12 | target_link_libraries(gfxappdemo PRIVATE | ||
13 | gfx-app) | ||
14 | |||
15 | target_compile_options(gfxappdemo PRIVATE -Wall -Wextra -Wpedantic) | ||