aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..b9102d0
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,23 @@
1cmake_minimum_required(VERSION 3.16)
2
3project(math)
4
5# Library.
6
7add_library(math INTERFACE)
8
9target_include_directories(math INTERFACE
10 include)
11
12target_link_libraries(math INTERFACE
13 -lm)
14
15# Test.
16
17add_executable(math_test
18 test/mat4_test.c)
19
20target_link_libraries(math_test
21 math)
22
23target_compile_options(math_test PRIVATE -DUNIT_TEST -DNDEBUG -Wall -Wextra)