diff options
author | 3gg <3gg@shellblade.net> | 2024-05-04 16:51:29 -0700 |
---|---|---|
committer | 3gg <3gg@shellblade.net> | 2024-05-04 16:51:29 -0700 |
commit | 8222bfe56d4dabe8d92fc4b25ea1b0163b16f3e1 (patch) | |
tree | 763389e42276035ac134d94eb1dc32293b88d807 /src/contrib/tinydir-1.2.4/CMakeLists.txt |
Initial commit.
Diffstat (limited to 'src/contrib/tinydir-1.2.4/CMakeLists.txt')
-rw-r--r-- | src/contrib/tinydir-1.2.4/CMakeLists.txt | 15 |
1 files changed, 15 insertions, 0 deletions
diff --git a/src/contrib/tinydir-1.2.4/CMakeLists.txt b/src/contrib/tinydir-1.2.4/CMakeLists.txt new file mode 100644 index 0000000..7d83854 --- /dev/null +++ b/src/contrib/tinydir-1.2.4/CMakeLists.txt | |||
@@ -0,0 +1,15 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | project(tinydir) | ||
4 | |||
5 | set(CMAKE_C_STANDARD 17) | ||
6 | set(CMAKE_C_STANDARD_REQUIRED On) | ||
7 | set(CMAKE_C_EXTENSIONS Off) | ||
8 | |||
9 | add_library(tinydir INTERFACE | ||
10 | tinydir.h) | ||
11 | |||
12 | target_include_directories(tinydir INTERFACE | ||
13 | .) | ||
14 | |||
15 | target_compile_options(tinydir INTERFACE -Wall -Wextra -Wpedantic) | ||