diff options
author | 3gg <3gg@shellblade.net> | 2023-07-11 18:37:45 -0700 |
---|---|---|
committer | 3gg <3gg@shellblade.net> | 2023-07-11 18:38:04 -0700 |
commit | fc5886c75ab2626acbc0d7b3db475d17d2cbe01f (patch) | |
tree | 1f84aabf268a40ddc6b4f5deef2450fca2171f6e /filesystem/CMakeLists.txt | |
parent | 2a016de1c2eb45fc5f9c8cebf6b3c726b01ec340 (diff) |
Add filesystem library.
Diffstat (limited to 'filesystem/CMakeLists.txt')
-rw-r--r-- | filesystem/CMakeLists.txt | 11 |
1 files changed, 11 insertions, 0 deletions
diff --git a/filesystem/CMakeLists.txt b/filesystem/CMakeLists.txt new file mode 100644 index 0000000..55430e6 --- /dev/null +++ b/filesystem/CMakeLists.txt | |||
@@ -0,0 +1,11 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | project(filesystem) | ||
4 | |||
5 | add_library(filesystem | ||
6 | src/filesystem.c) | ||
7 | |||
8 | target_include_directories(filesystem PUBLIC | ||
9 | include) | ||
10 | |||
11 | target_compile_options(filesystem PRIVATE -Wall -Wextra) | ||