diff options
Diffstat (limited to 'filesystem/CMakeLists.txt')
-rw-r--r-- | filesystem/CMakeLists.txt | 11 |
1 files changed, 11 insertions, 0 deletions
diff --git a/filesystem/CMakeLists.txt b/filesystem/CMakeLists.txt new file mode 100644 index 0000000..55430e6 --- /dev/null +++ b/filesystem/CMakeLists.txt | |||
@@ -0,0 +1,11 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | ||
2 | |||
3 | project(filesystem) | ||
4 | |||
5 | add_library(filesystem | ||
6 | src/filesystem.c) | ||
7 | |||
8 | target_include_directories(filesystem PUBLIC | ||
9 | include) | ||
10 | |||
11 | target_compile_options(filesystem PRIVATE -Wall -Wextra) | ||