aboutsummaryrefslogtreecommitdiff
path: root/contrib/glfw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/glfw/CMakeLists.txt')
-rw-r--r--contrib/glfw/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/contrib/glfw/CMakeLists.txt b/contrib/glfw/CMakeLists.txt
new file mode 100644
index 0000000..a4e4955
--- /dev/null
+++ b/contrib/glfw/CMakeLists.txt
@@ -0,0 +1,11 @@
1cmake_minimum_required(VERSION 3.0)
2
3add_library(glfw INTERFACE)
4
5set(GLFW_DIR ${CMAKE_CURRENT_SOURCE_DIR}/glfw-3.3.5.bin.WIN64)
6
7target_include_directories(glfw INTERFACE
8 ${GLFW_DIR}/include)
9
10target_link_libraries(glfw INTERFACE
11 ${GLFW_DIR}/lib-vc2019/glfw3_mt.lib)