diff options
author | 3gg <3gg@shellblade.net> | 2024-08-31 18:58:39 -0700 |
---|---|---|
committer | 3gg <3gg@shellblade.net> | 2024-08-31 18:58:39 -0700 |
commit | daf6262c029892212f6b9b4014887c2c37e9ef75 (patch) | |
tree | 40b24f4f23cc48e55c3511c28c7bef29834d61b3 /gfx-iso/CMakeLists.txt | |
parent | 0a78a9d9c1ac2090da56f395d6f2394a8a210010 (diff) |
Handle resizing.
Diffstat (limited to 'gfx-iso/CMakeLists.txt')
-rw-r--r-- | gfx-iso/CMakeLists.txt | 15 |
1 files changed, 7 insertions, 8 deletions
diff --git a/gfx-iso/CMakeLists.txt b/gfx-iso/CMakeLists.txt index 673cb68..e4a677d 100644 --- a/gfx-iso/CMakeLists.txt +++ b/gfx-iso/CMakeLists.txt | |||
@@ -21,22 +21,21 @@ target_link_libraries(isogfx PUBLIC | |||
21 | 21 | ||
22 | target_compile_options(isogfx PRIVATE -Wall -Wextra -Wpedantic) | 22 | target_compile_options(isogfx PRIVATE -Wall -Wextra -Wpedantic) |
23 | 23 | ||
24 | # App | 24 | # Backend |
25 | 25 | ||
26 | add_library(isogfx-app | 26 | add_library(isogfx-backend |
27 | src/app.c) | 27 | src/backend.c) |
28 | 28 | ||
29 | target_include_directories(isogfx-app PUBLIC | 29 | target_include_directories(isogfx-backend PUBLIC |
30 | include) | 30 | include) |
31 | 31 | ||
32 | target_link_libraries(isogfx-app PUBLIC | 32 | target_link_libraries(isogfx-backend PUBLIC |
33 | gfx-app | ||
34 | isogfx) | 33 | isogfx) |
35 | 34 | ||
36 | target_link_libraries(isogfx-app PRIVATE | 35 | target_link_libraries(isogfx-backend PRIVATE |
37 | gfx) | 36 | gfx) |
38 | 37 | ||
39 | target_compile_options(isogfx-app PRIVATE -Wall -Wextra -Wpedantic) | 38 | target_compile_options(isogfx-backend PRIVATE -Wall -Wextra -Wpedantic) |
40 | 39 | ||
41 | # Demos | 40 | # Demos |
42 | 41 | ||